Cara configurasi MPLS VPLS BGP Signaling di RouterOS

 








Router P1

/interface bridge

add name=bridge1

add name=lo


/interface bridge port

add bridge=bridge1 interface=ether10-customer



/ip address

add address=192.168.1.1/30 interface=ether1-primary network=192.168.1.0

add address=192.168.2.1/30 interface=ether2-backup network=192.168.2.0

add address=1.1.1.1 interface=lo network=1.1.1.1


/routing ospf instance

set [ find default=yes ] router-id=1.1.1.1

/routing ospf interface

add cost=5 interface=ether1-primary network-type=point-to-point

add interface=ether2-backup network-type=point-to-point

/routing ospf network

add area=backbone network=1.1.1.1/32

add area=backbone network=192.168.1.0/30

add area=backbone network=192.168.2.0/30


/mpls ldp

set enabled=yes lsr-id=1.1.1.1 transport-address=1.1.1.1

/mpls ldp interface

add interface=ether1-primary

add interface=ether2-backup



/routing bgp instance

set default as=65000 router-id=1.1.1.1

/routing bgp peer

add address-families=l2vpn name=Peer-P4 remote-address=4.4.4.4 remote-as=65000 update-source=lo

add address-families=l2vpn name=Peer-P2 remote-address=2.2.2.2 remote-as=65000 update-source=lo

add address-families=l2vpn name=Peer-P3 remote-address=3.3.3.3 remote-as=65000 update-source=lo


/interface vpls bgp-vpls

add bridge=bridge1 bridge-cost=10 export-route-targets=65000:1 import-route-targets=65000:1 name=Customer-A route-distinguisher=65000:1


Router P2

P2

/interface bridge

add name=bridge1

add name=lo

/interface bridge port

add bridge=bridge1 interface=ether10-customer


/ip address

add address=192.168.1.2/30 interface=ether1-primary network=192.168.1.0

add address=192.168.3.1/30 interface=ether2-backup network=192.168.3.0

add address=2.2.2.2 interface=lo network=2.2.2.2


/routing ospf instance

set [ find default=yes ] router-id=2.2.2.2

/routing ospf interface

add cost=5 interface=ether1-primary network-type=point-to-point

add interface=ether2-backup network-type=point-to-point

/routing ospf network

add area=backbone network=2.2.2.2/32

add area=backbone network=192.168.1.0/30

add area=backbone network=192.168.3.0/30


/mpls ldp

set enabled=yes lsr-id=2.2.2.2 transport-address=2.2.2.2

/mpls ldp interface

add interface=ether1-primary

add interface=ether2-backup


/routing bgp instance

set default as=65000 router-id=2.2.2.2

/routing bgp peer

add address-families=l2vpn name=Peer-P1 remote-address=1.1.1.1 remote-as=65000 update-source=lo

add address-families=l2vpn name=Peer-P4 remote-address=4.4.4.4 remote-as=65000 update-source=lo

add address-families=l2vpn name=Peer-P3 remote-address=3.3.3.3 remote-as=65000 update-source=lo


/interface vpls bgp-vpls

add bridge=bridge1 bridge-cost=10 export-route-targets=65000:1 import-route-targets=65000:1 name=Customer-A route-distinguisher=65000:1 site-id=2


Router P3

/interface bridge

add name=bridge1

add name=lo

/interface bridge port

add bridge=bridge1 interface=ether10-customer


/ip address

add address=192.168.2.2/30 interface=ether1-primary network=192.168.2.0

add address=192.168.4.1/30 interface=ether2-backup network=192.168.4.0

add address=3.3.3.3 interface=lo network=3.3.3.3


/routing ospf instance

set [ find default=yes ] router-id=3.3.3.3

/routing ospf interface

add cost=5 interface=ether1-primary network-type=point-to-point

add interface=ether2-backup network-type=point-to-point

/routing ospf network

add area=backbone network=3.3.3.3/32

add area=backbone network=192.168.2.0/30

add area=backbone network=192.168.4.0/30


/mpls ldp

set enabled=yes lsr-id=3.3.3.3 transport-address=3.3.3.3

/mpls ldp interface

add interface=ether1-primary

add interface=ether2-backup



/routing bgp instance

set default as=65000 router-id=3.3.3.3

/routing bgp peer

add address-families=l2vpn name=Peer-P1 remote-address=1.1.1.1 remote-as=65000 update-source=lo

add address-families=l2vpn name=Peer-P2 remote-address=2.2.2.2 remote-as=65000 update-source=lo

add address-families=l2vpn name=Peer-P4 remote-address=4.4.4.4 remote-as=65000 update-source=lo


/interface vpls bgp-vpls

add bridge=bridge1 bridge-cost=10 export-route-targets=65000:1 import-route-targets=65000:1 name=Customer-A route-distinguisher=65000:1 site-id=3


Router P4
/interface bridge
add name=bridge1
add name=lo
/interface bridge port
add bridge=bridge1 interface=ether10-customer

/ip address
add address=192.168.3.2/30 interface=ether1-primary network=192.168.3.0
add address=192.168.4.2/30 interface=ether2-backup network=192.168.4.0
add address=4.4.4.4 interface=lo network=4.4.4.4

/routing ospf instance
set [ find default=yes ] router-id=4.4.4.4
/routing ospf interface
add cost=5 interface=ether1-primary network-type=point-to-point
add interface=ether2-backup network-type=point-to-point
/routing ospf network
add area=backbone network=4.4.4.4/32
add area=backbone network=192.168.3.0/30
add area=backbone network=192.168.4.0/30

/mpls ldp
set enabled=yes lsr-id=4.4.4.4 transport-address=4.4.4.4
/mpls ldp interface
add interface=ether1-primary
add interface=ether2-backup


/routing bgp instance
set default as=65000 router-id=4.4.4.4
/routing bgp peer
add address-families=l2vpn name=Peer-P1 remote-address=1.1.1.1 remote-as=65000 update-source=lo
add address-families=l2vpn name=Peer-P2 remote-address=2.2.2.2 remote-as=65000 update-source=lo
add address-families=l2vpn name=Peer-P3 remote-address=3.3.3.3 remote-as=65000 update-source=lo


/interface vpls bgp-vpls
add bridge=bridge1 bridge-cost=10 export-route-targets=65000:1 import-route-targets=65000:1 name=Customer-A route-distinguisher=65000:1 site-id=4


Semoga Bermanfaat

Penulis : Een Pahlefi,S.Kom

0 Response to "Cara configurasi MPLS VPLS BGP Signaling di RouterOS"

Post a Comment

Iklan Atas Artikel

Iklan Tengah Artikel 1

Iklan Tengah Artikel 2

Iklan Bawah Artikel